IX2015のセンタールーターと拠点ルータが完成!

2008年10月24日 2 投稿者: ぱる☆ミ

自宅をセンタールーター、実家や友人宅を拠点ルーターとした構成が完成(^^)

センタールーター側

NEC Portable Internetwork Core Operating System Software
IX Series IX2010 (magellan-sec) Software, Version 8.2.19, RELEASE SOFTWARE
Compiled Jul 11-Fri-2008 10:49:00 JST #1
Current time Oct 24-Fri-2008 00:32:09 JST
hostname amu
timezone +09 00
ntp ip enable
ntp server 133.243.238.163
ntp server 133.243.238.243
ntp interval 3600
logging buffered 4096
logging subsystem all error
logging timestamp datetime
ip route default x.x.x.x
ip route 10.80.b.0/24 Tunnel1.0
ip route 192.168.x.0/24 Tunnel0.0
ip route 192.168.y.0/24 Tunnel0.0
ip route 192.168.z.0/24 Tunnel0.0
ip access-list sec-list permit ip src 10.80.a.0/24 dest 192.168.x.0/24
ip access-list sec-list permit ip src 10.80.a.0/24 dest 192.168.y.0/24
ip access-list sec-list permit ip src 10.80.a.0/24 dest 192.168.z.0/24
ip access-list sec-palzikka permit ip src any dest any
ip ufs-cache enable
arp auto-refresh
ike proposal ikeprop encryption aes hash sha
ike policy ike-o-policy peer any key XXX mode aggressive ikeprop
ike commit-bit ike-o-policy
ike remote-id ike-o-policy keyid XXXX
ike policy ike-policy peer any key XXX ikeprop
ipsec autokey-proposal secprop esp-aes esp-sha
ipsec autokey-map ipsec-policy sec-list peer x.x.x.x secprop
ipsec local-id ipsec-policy 10.80.a.0/24
ipsec remote-id ipsec-policy 192.168.x.x/x
ipsec dynamic-map ipsec-o-policy sec-palzikka secprop ike ike-o-policy
ipsec commit-bit ipsec-o-policy
ipsec local-id ipsec-o-policy 10.80.a.0/24
ipsec remote-id ipsec-o-policy 10.80.b.0/24
proxy-dns ip enable
proxy-dns server x.x.x.x priolity 200
proxy-dns server y.y.y.y
interface FastEthernet0/0.0
ip address x.x.x.x/25
ip tcp adjust-mss auto
no shutdown
interface FastEthernet0/1.0
no ip address
shutdown
interface FastEthernet1/0.0
ip address 10.80.a.200/24
ip tcp adjust-mss auto
no shutdown
interface Tunnel0.0
tunnel mode ipsec
ip unnumbered FastEthernet1/0.0
ip tcp adjust-mss auto
ipsec policy tunnel ipsec-policy out
no shutdown
interface Tunnel1.0
description PalZikka
tunnel mode ipsec
ip unnumbered FastEthernet1/0.0
ip tcp adjust-mss auto
ipsec policy tunnel ipsec-o-policy out
no shutdown

そして実家側。この下に無線LANルータのアクセスポイントが入るのだけれども、同じ機種が自宅にもあるので試験済み。こういうとき環境を合わせておくと便利だねw

NEC Portable Internetwork Core Operating System Software
IX Series IX2010 (magellan-sec) Software, Version 8.2.19, RELEASE SOFTWARE
Compiled Jul 11-Fri-2008 10:49:00 JST #1
Current time Oct 24-Fri-2008 00:20:10 JST
hostname ran
timezone +09 00
ntp ip enable
ntp server 133.243.238.163
ntp server 133.243.238.243
ntp interval 3600
ip route 10.80.a.0/24 Tunnel0.0
ip dhcp enable
ip access-list sec-list permit ip src 10.80.b.0/24 dest 10.80.a.0/24
ip ufs-cache enable
arp auto-refresh
ike proposal ikeprop encryption aes hash sha
ike suppress-dangling
ike policy ike-policy peer x.x.x.x key XXXX mode aggressive ikeprop
ike keepalive ike-policy 30 6
ike local-id ike-policy keyid xxxx
ipsec autokey-proposal secprop esp-aes esp-sha
ipsec autokey-map ipsec-policy sec-list peer x.x.x.x secprop
ipsec local-id ipsec-policy 10.80.b.0/24
ipsec remote-id ipsec-policy 10.80.a.0/24
proxy-dns ip enable
proxy-dns server x.x.x.x priority 200
proxy-dns server y.y.y.y
ip dhcp profile dhcp_hub
dns-server 10.80.b.1
interface FastEthernet0/0.0
description CATV_line
ip address dhcp receive-default
ip napt enable
no shutdown
interface FastEthernet0/1.0
ip address 10.80.b.1/24
ip dhcp binding dhcp_hub
no shutdown
interface Tunnel0.0
description To_pal
tunnel mode ipsec
ip unnumbered FastEthernet0/1.0
ipsec policy tunnel ipsec-policy out
no shutdown

これで実家のPCを自宅のWindows Home Serverでバックアップさせる事も出来るかな。
ケーブルモデムの下だとリモートデスクトップにも制約があって非常に面倒だったから、これからはトンネル経由にすればいいし非常に楽だねw
そういえば某Q氏もIX2015を購入したらしい。もうメインモードでもアグレッシブモードでも設定できるからいつでも来なさいw
Tunnel0.0内で、HD画質の動画を見ながらファイルを転送したところ、20Mbyte/secと十分実用になる数値が叩き出せた。流石にハードウェアで暗号処理しているだけはあるか。
以前のOpenVPNではこんな数字はどう転んでも出せなかったなぁ(^^;
本日現在の概要図